Support Services Impacted
Incident Report for aXcelerate
Resolved
This incident has been resolved.
Posted Apr 30, 2024 - 16:07 AEST
Investigating
Due to an internal system issue at the aXcelerate Head Office, our phone and live chat support services are currently unavailable. The aXcelerate platform will continue to operate unaffected. Please submit a support request via our Help Centre if you require assistance. We apologise for the inconvenience this may cause.
Posted Apr 30, 2024 - 15:14 AEST
This incident affected: Support services.